HVIS, SÅ, OG/ELLER

Løst
Dette emne indeholder 3 svar, har 3 stemmer og blev senest opdateret af  mirob9 6 måneder, 2 uger siden.
Oprettet af
mirob9
Abonnent

Programmets navn: Excel 2016
Spørgsmål: Hej alle. Jeg har en Excel udfordring, som jeg håber nogen kan hjælpe med.
Jeg har et Excel ark, som jeg gerne vil automatisere noget mere. Pba. en aldersangivelse, vil jeg gerne have Excel til at skrive, om en person er følgende:

– Under 30
– 30-39
-40-49
– 50-59
– 60 år og derover

Så hvis der i A1 står “30”, skal Excel i B1 skrive “Under 30”
og hvis der i A2 står “61”, skal Excel i B2 skrive “60 år og derover”

Jeg har forsøgt mig med en formel, der starter sådan her:

=HVIS(A1<30;”Under 30″… Og jeg ved, jeg skal have flettet ELLER ind et sted, jeg ved bare ikke hvordan

HenrikClausen
HenrikClausen
Komputer for alle

    Det kan gøres med en formel som denne:

    =HVIS(C2<30; “Test”; HVIS(C2<50; “Tast”; “Tyst”))

    Finten er, at den sidste af de tre parametre til HVIS(;;) er ‘ELLER’-delen – og der kan du indsætte et helt HVIS(;;) igen. Det kan du gøre lige så dybt, du har brug for.


    kaj-emil
    Abonnent

      Hej mirob9

      Jeg har skrevet den lille beskedne formel, du bad om, den er indlagt i vedhæftede regneark under kolonnen uden navn.

      =HVIS($C6=””;””;HVIS($C6<30;”Under 30″;HVIS(OG($C6>=30;$C6<40);”30-39″;HVIS(OG($C6>=40;$C6<50);”40-49″;HVIS(OG($C6>=50;$C6<60);”50-59″;HVIS($C6>=60;”60 år og derover”;””))))))

      Jeg gør samtidig opmærksom på, at når man har, så mange betingelser som her nedsættes hastigheden.

      En anden og bedre løsning vil være (min mening), at bruge opslag, det er angivet i samme (vedlagte) regneark under kolonnen Aldersangivelse med tilhørende ark Opslag.

      Med venlig hilsen

      Kaj-Emil

      Vedhæftede filer:
      1. Hvis_og_eller_Lopslag.ods

      mirob9
      Abonnent

        Hej begge.

        Mange tak for hjælpen og jeres gode svar. 🙂

        Du skal være abonnent for at skrive et indlæg